Skip to content
Snippets Groups Projects
PKGBUILD 2.63 KiB
# Obarun        : 66 init/supervisor
# Maintainer    : Eric Vidal <eric@obarun.org>
# Maintainer    : Jean-Michel T.Dydak <jean-michel@obarun.org>
# PkgSource     : url="https://git.obarun.org/pkg/obcommunity/weston"
#-----------------------------------------------------------------------------------------------

#-----------------------------------------| DESCRIPTION |---------------------------------------

pkgname=weston

pkgdesc='Reference implementation of a Wayland compositor'

pkgver=14.0.1
pkgrel=2

url='https://wayland.freedesktop.org/'

source=("https://gitlab.freedesktop.org/wayland/weston/-/releases/$pkgver/downloads/weston-$pkgver.tar.xz"{,.sig})

#-------------------------------------| BUILD CONFIGURATION |-----------------------------------

makedepends=('wayland-protocols' 'meson' 'ninja' 'freerdp' 'neatvnc' 'libpipewire'
	'xorg-xwayland' 'xcb-util-cursor' 'libdisplay-info')

#--------------------------------------| BUILD PREPARATION |------------------------------------

prepare() {
  cd $pkgname-$pkgver
}

#--------------------------------------------| BUILD |------------------------------------------

build() {
  arch-meson $pkgname-$pkgver build \
    --libexec=lib/weston \
    -Db_lto=false \
    -Dsystemd=false 
    ninja -C build


}

#-------------------------------------------| PACKAGE |-----------------------------------------

package() {
  DESTDIR="$pkgdir" meson install -C build
  # license
  install -Dm644 $pkgname-$pkgver/COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}

#------------------------------------| INSTALL CONFIGURATION |----------------------------------

arch=('x86_64')

depends=(
    'glibc'
    'wayland'
    'libxkbcommon'
    'libinput'
    'libunwind'
    'pixman'
    'libdrm'
    'pam'
    'cairo'
    'libpng'
    'libjpeg-turbo'
    'libwebp'
    'mesa'
    'libegl'
    'libgles'
    'glib2'
    'pango'
    'lcms2'
    'mtdev'
    'libx11'
    'libxcb'
    'dbus'
    'libva'
    'libxcursor'
    'colord'
    'seatd'
    'gstreamer'
    'gst-plugins-base-libs')

optdepends=(
	'xorg-xwayland: support x11 backend'
	'libpipewire: support pipewire backend'
	'freerdp: support rdp backend'
	'neatvnc: support vnc backend'
	)

#-------------------------------------| SECURITY AND LICENCE |----------------------------------

license=('MIT')

sha256sums=(' '
'SKIP')

validpgpkeys=('7032877A3EB1EAE3E4DC9DFBF63412E60947D6EF' # Marius Vlad <marius.vlad@collabora.com>
              '34FF9526CFEF0E97A340E2E40FDE7BE0E88F5E48' # emersion <contact@emersion.fr>
              'C7223EBE4EF66513B892598911A30156E0E67611' # Bryce Harrington
              'C0066D7DB8E9AC6844D728715E54498E697F11D7') # Derek Foreman